Vulnerability · Published Nov 4, 2026 · Assigned by apache

CVE-2026-108946Apache ActiveMQ, ActiveMQ Broker: The broker does not verify user provided connection id matches connection

Unrated

In plain English

A improper input validation in ActiveMQ Broker from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 14% of all known vulnerabilities).

Severity (CVSS )–Not rated
Exploit odds (30 days)0.2%top 86.2% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Improper input validation vulnerability in Apache ActiveMQ, Apache ActiveMQ KahaDB. The ActiveMQ broker resolves connection, session and consumer state from ids that are user provided and in some scenarios does not validate that they ids are bound to that user. This allows an authenticated client to spoof another user's ids. This allows: *  an authenticated client consumes from another connection's temporary queue/topic by putting the victim's connection id in its own ConsumerId, bypassing the broker-side ownership check.  * a duplicate ConsumerId registration is only logged, after which the attacker's RemoveInfo or disconnect tears down the victim's live subscription * a forged MessageAck for the victim's ConsumerId permanently deletes an in-flight, unacknowledged message. This issue affects Apache ActiveMQ: from 6.0.0 before 6.3.3, before 5.19.12; Apache ActiveMQ KahaDB: from 6.0.0 before 6.3.3, before 5.19.12. Users are recommended to upgrade to version 6.4.0, 6.3.3, or 5.19.12, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12activemqno fix listedDEBIAN-CVE-2026-108946
Debian:13activemqno fix listedDEBIAN-CVE-2026-108946
Ubuntu:24.04:LTSactivemqno fix listedUBUNTU-CVE-2026-108946
Ubuntu:26.04:LTSactivemqno fix listedUBUNTU-CVE-2026-108946
Ubuntu:26.10activemqno fix listedUBUNTU-CVE-2026-108946

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache ActiveMQ 6.0.0 – before 6.3.30 – before 5.19.12
Apache Software Foundation ActiveMQ Broker 6.0.0 – before 6.3.30 – before 5.19.12

Weakness: CWE-20

References