Vulnerability · Published Oct 12, 2026 · Assigned by VulDB

CVE-2026-108822Kamailio sipt ss7_parser.c isup_get_calling_party buffer overflow

Medium 5.3

In plain English

A medium-severity buffer overflow in Kamailio. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 41% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.3Medium
Exploit odds (30 days)0.5%top 58.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

A vulnerability was detected in Kamailio up to 6.0.7/6.1.3. The affected element is the function isup_get_calling_party of the file src/modules/sipt/ss7_parser.c of the component sipt Module. The manipulation of the argument length results in buffer overflow. The attack may be performed from remote. Upgrading to version 6.0.8 and 6.1.4 is sufficient to fix this issue. The patch is identified as 3667bebf8d0bea07ed16218fd921d07db87aeb21. Upgrading the affected component is advised.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12kamailiono fix listedDEBIAN-CVE-2026-108822
Debian:13kamailiono fix listedDEBIAN-CVE-2026-108822
Debian:14kamailio6.1.5-1DEBIAN-CVE-2026-108822
Ubuntu:22.04:LTSkamailiono fix listedUBUNTU-CVE-2026-108822
Ubuntu:24.04:LTSkamailiono fix listedUBUNTU-CVE-2026-108822
Ubuntu:26.04:LTSkamailiono fix listedUBUNTU-CVE-2026-108822
Ubuntu:26.10kamailiono fix listedUBUNTU-CVE-2026-108822

Affected products (as reported)

VendorProductVersions
n/a Kamailio 6.0.06.0.16.0.26.0.36.0.46.0.56.0.66.0.7

Weakness: CWE-120, CWE-119 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L/E:X/RL:O/RC:C

References