Vulnerability · Published Nov 4, 2026 · Assigned by apache
CVE-2026-108500Apache ActiveMQ: LDAPAuthorizationMap allows authorization bypass via DN injection
Unrated
In plain English
A improper input validation in Apache ActiveMQ from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 12% of all known vulnerabilities).
Official description
Input validation vulnerability in Apache ActiveMQ configured to use the LDAPAuthorizationMapPlugin allows an authenticated attacker to create or address a destination with a crafted name containing LDAP DN special characters (such as comma, plus, equals, backslash) can manipulate the LDAP search base used for ACL lookups. This issue affects Apache ActiveMQ: from 6.3.0 before 6.3.3, from 5.19.0 before 5.19.12. Users are recommended to upgrade to version 6.4.0, 6.3.3 or 5.19.12, which fixes the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | activemq | no fix listed | DEBIAN-CVE-2026-108500 |
| Debian:13 | activemq | no fix listed | DEBIAN-CVE-2026-108500 |
| Ubuntu:24.04:LTS | activemq | no fix listed | UBUNTU-CVE-2026-108500 |
| Ubuntu:26.04:LTS | activemq | no fix listed | UBUNTU-CVE-2026-108500 |
| Ubuntu:26.10 | activemq | no fix listed | UBUNTU-CVE-2026-108500 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache ActiveMQ | 6.3.0 – before 6.3.35.19.0 – before 5.19.12 |
Weakness: CWE-20