Vulnerability · Published Oct 9, 2026 · Assigned by GitHub_M

CVE-2026-107845Contao: Cross-site scripting in the comments bundle

Critical 9.3

In plain English

A critical-severity cross-site scripting in contao from contao. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 20% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)9.3Critical
Exploit odds (30 days)0.3%top 79.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Contao is an Open Source CMS. From version 4.0.0 until 5.3.50 and 5.7.12, an unauthenticated visitor can submit a comment whose email or website metadata is rendered without sufficient attribute and URL encoding by listComments() in comments-bundle/contao/dca/tl_comments.php. When a backend user opens the Comments module, attacker-controlled script can execute in the Contao backend origin under that user's session. Unpublished comments remain visible to moderators, so moderation does not prevent exposure. This issue is fixed in versions 5.3.50 and 5.7.12.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistcontao/comments-bundle5.3.50GHSA-628f-v4f6-p37r
Packagistcontao/comments-bundle5.7.12GHSA-628f-v4f6-p37r

Affected products (as reported)

VendorProductVersions
contao contao >= 4.0.0, < 5.3.50>= 5.4.0-RC1, < 5.7.12

Weakness: CWE-79, CWE-116 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N

References