Vulnerability · Published Oct 9, 2026 · Assigned by GitHub_M

CVE-2026-107821MariaDB: insufficient validation of binary frm data when opening a table

High 8.0

In plain English

A high-severity security flaw in server from MariaDB. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 68% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.0High
Exploit odds (30 days)1.2%top 31.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

MariaDB server is a community developed fork of MySQL server. From 10.6.1 until 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2, MariaDB insufficiently validated counts, offsets, lengths, and field boundaries in FRM metadata while opening binary FRM files. An attacker able to place a crafted FRM file in the data directory could trigger out-of-bounds reads or writes, crash the server, or potentially execute code. This issue is fixed in versions 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12mariadbno fix listedDEBIAN-CVE-2026-107821
Debian:13mariadbno fix listedDEBIAN-CVE-2026-107821
Debian:14mariadb1:11.8.9+ds-1DEBIAN-CVE-2026-107821
Ubuntu:24.04:LTSmariadbno fix listedUBUNTU-CVE-2026-107821
Ubuntu:26.04:LTSmariadbno fix listedUBUNTU-CVE-2026-107821
Ubuntu:26.10mariadbno fix listedUBUNTU-CVE-2026-107821
Ubuntu:22.04:LTSmariadb-10.6no fix listedUBUNTU-CVE-2026-107821

Affected products (as reported)

VendorProductVersions
MariaDB server >= 10.6.1, < 10.6.28>= 10.11.1, < 10.11.19>= 11.4.1, < 11.4.13>= 11.8.1, < 11.8.9>= 12.3.1, < 12.3.3>= 13.0.1, < 13.0.2

Weakness: CWE-1285 · Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H

References