Vulnerability · Published Oct 9, 2026 · Assigned by GitHub_M

CVE-2026-107818MariaDB: environment injection via wsrep bootstrap in the mariadb.service file

High 8.4

In plain English

A high-severity security flaw in server from MariaDB. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 35% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.4High
Exploit odds (30 days)0.4%top 65.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

MariaDB server is a community developed fork of MySQL server. From 10.6.1 until 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2, the mariadb.service unit used /run/mysqld/wsrep-new-cluster during the next service restart. A database user with FILE privilege and a secure-file-priv configuration permitting writes to /run/mysqld could create that file and inject attacker-controlled environment values into the restarted service. This issue is fixed in versions 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12mariadbno fix listedDEBIAN-CVE-2026-107818
Debian:13mariadbno fix listedDEBIAN-CVE-2026-107818
Debian:14mariadb1:11.8.9+ds-1DEBIAN-CVE-2026-107818
Ubuntu:24.04:LTSmariadbno fix listedUBUNTU-CVE-2026-107818
Ubuntu:26.04:LTSmariadbno fix listedUBUNTU-CVE-2026-107818
Ubuntu:26.10mariadbno fix listedUBUNTU-CVE-2026-107818
Ubuntu:22.04:LTSmariadb-10.6no fix listedUBUNTU-CVE-2026-107818

Affected products (as reported)

VendorProductVersions
MariaDB server >= 10.6.1, < 10.6.28>= 10.11.1, < 10.11.19>= 11.4.1, < 11.4.13>= 11.8.1, < 11.8.9>= 12.3.1, < 12.3.3>= 13.0.1, < 13.0.2

Weakness: CWE-15 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H

References