Vulnerability · Published Oct 9, 2026 · Assigned by GitHub_M

CVE-2026-107809Nginx-UI AuthRequired token cookie fallback enables CSRF against management APIs

High 8.8

In plain English

A high-severity cross-site request forgery in nginx-ui from 0xJacky. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 13% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.8High
Exploit odds (30 days)0.2%top 86.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Nginx UI is a web user interface for the Nginx web server. From 2.0.0 until 2.5.0, AuthRequired accepts a browser-managed token cookie as an API credential after the front end stores the JWT in that cookie. Because management endpoints do not universally require a CSRF token or perform Origin or Referer validation, a remote attacker can induce a logged-in administrator's browser to submit authenticated cross-site state-changing requests, including POST /api/configs. The attack requires an administrator account without OTP/Passkey or a target endpoint that does not require secure-session proof. The attacker cannot read the cross-origin response but can modify Nginx configuration, trigger reloads, or invoke other management operations reachable with the victim's session. This issue is fixed in version 2.5.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Gogithub.com/0xJacky/Nginx-UI1.9.10-0.20260728074433-a3999bd78a3bGHSA-33rr-wq23-g6gg
Gogithub.com/0xJacky/Nginx-UI1.9.10-0.20260728074433-a3999bd78a3bGO-2026-6703

Affected products (as reported)

VendorProductVersions
0xJacky nginx-ui >= 2.0.0, < 2.5.0

Weakness: CWE-352 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

References