Vulnerability · Published Oct 8, 2026 · Assigned by AMZN
CVE-2026-107322OS command injection in Amazon Agent Plugins for AWS databases-on-aws
High 7.8
In plain English
A high-severity security flaw in databases-on-aws from aws. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 2% of all known vulnerabilities).
Official description
An incomplete list of disallowed inputs in Amazon Agent Plugins for AWS databases-on-aws plugin before 1.7.1 might allow a remote unauthenticated actor to execute arbitrary operating system commands on the host running the helper via a crafted database command value introduced in the agent context. To remediate this issue, users should upgrade to databases-on-aws plugin version 1.7.1 or later and verify that the updated plugin is active in each environment where it is used.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| aws | databases-on-aws | 0 – before 1.7.1 |
Weakness: CWE-184 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H