Vulnerability · Published Oct 8, 2026 · Assigned by GitHub_M
CVE-2026-107298msgpack5: Deeply nested input can exhaust the decoder stack
Medium 5.3
In plain English
A medium-severity security flaw in msgpack5 from mcollina. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 31% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
msgpack5 is a msgpack v5 implementation for node.js and the browser. Prior to 6.1.0, the array and map decoding paths have no nesting-depth limit, allowing an attacker who can provide MessagePack input to submit deeply nested containers that exhaust the JavaScript call stack and interrupt a process, worker, or request handler. This issue is fixed in version 6.1.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | msgpack5 | 6.1.0 | GHSA-24ch-f2g6-9hhh |
Affected products (as reported)
Weakness: CWE-674 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
References
- https://github.com/mcollina/msgpack5/security/advisories/GHSA-24ch-f2g6-9hhh x_refsource_CONFIRM
- https://github.com/mcollina/msgpack5/commit/1e2b5874e555dd7c99417f64788a03b0590bb102 x_refsource_MISC
- https://github.com/mcollina/msgpack5/releases/tag/v6.1.0 x_refsource_MISC