Vulnerability · Published Oct 8, 2026 · Assigned by openjs
CVE-2026-107275@fastify/jwt vulnerable to missing token expiration when temporal options cannot be parsed
Medium 6.8
In plain English
A medium-severity security flaw in @fastify/jwt from @fastify/jwt. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 24% of all known vulnerabilities).
Official description
@fastify/jwt is a JSON Web Token plugin for the Fastify web framework. In versions before 10.2.3, a time span passed to expiresIn, notBefore, or maxAge that the plugin's parser cannot read, such as a compound span, a month unit, an ISO 8601 duration, a decimal comma, or a value with surrounding whitespace, is silently dropped instead of refused. On the signing path this produces a token with no expiration claim that never expires, and on the verification path a configured maxAge stops being enforced, so a token that should be rejected for age is accepted. The issue is fixed in @fastify/jwt 10.2.3, and users should upgrade to 10.2.3 or later. As a workaround, pass these options as a number of seconds, or verify that any time-span string parses to a finite value before relying on it.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| @fastify/jwt | @fastify/jwt | 0 – before 10.2.3 |
Weakness: CWE-390, CWE-613, CWE-754 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N