Vulnerability · Published Oct 7, 2026 · Assigned by GitHub_M
CVE-2026-106563Backstage: Improper entity validation in deprecated Kubernetes services endpoint
Medium 5.3
In plain English
A medium-severity improper input validation in backstage from backstage. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 13% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Backstage is an open framework for building developer portals. Prior to 0.21.8, the @backstage/plugin-kubernetes-backend package is affected by improper entity validation in deprecated kubernetes services endpoint. An authenticated user with Kubernetes read permissions could access Kubernetes workload data beyond their intended scope by supplying crafted entity data to the deprecated services endpoint. The exposure is limited to read-only access to Kubernetes object metadata across configured clusters. This issue is fixed in version 0.21.8.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @backstage/plugin-kubernetes-backend | 0.21.8 | GHSA-r9ph-3637-55px |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| backstage | backstage | < 1.54.1 |
| @backstage | plugin-kubernetes-backend | < 0.21.8 |
Weakness: CWE-20, CWE-862 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N