Vulnerability · Published Oct 7, 2026 · Assigned by GitHub_M
CVE-2026-106559Backstage: Improper input validation in Confluence to Markdown scaffolder module
Medium 6.3
In plain English
A medium-severity path traversal in backstage from backstage. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 27% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Backstage is an open framework for building developer portals. Prior to 0.3.25, the @backstage/plugin-scaffolder-backend-module-confluence-to-markdown package is affected by improper input validation in confluence to markdown scaffolder module. Insufficient input validation in the Confluence to Markdown scaffolder module could allow an attacker to influence file write operations during template execution. Exploitation requires a Backstage user to run a template that processes attacker-influenced Confluence content. This issue is fixed in version 0.3.25.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @backstage/plugin-scaffolder-backend-module-confluence-to-markdown | 0.3.25 | GHSA-75qf-886x-5xf2 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| backstage | backstage | < 1.54.6 |
| @backstage | plugin-scaffolder-backend-module-confluence-to-markdown | < 0.3.25 |
Weakness: CWE-22, CWE-73 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:H/A:L