Vulnerability · Published Oct 7, 2026 · Assigned by GitHub_M

CVE-2026-106557Backstage: Improper input validation in TechDocs Markdown extension configuration

High 7.7

In plain English

A high-severity path traversal in backstage from backstage. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 32% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.7High
Exploit odds (30 days)0.4%top 68.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Backstage is an open framework for building developer portals. Prior to 1.14.6 and 1.15.4, the @backstage/plugin-techdocs-node package did not sufficiently validate TechDocs Markdown extension configuration. An authenticated user who can register or modify documentation sources may cause a TechDocs build to access resources outside the intended documentation boundary, potentially exposing backend-host data or internal network resources. This issue is fixed in versions 1.14.6 and 1.15.4 when pymdown-extensions 10.21.3 or later is also used, normally through mkdocs-techdocs-core 1.7.0 or later.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@backstage/plugin-techdocs-node1.15.4GHSA-f7v3-xhm6-w245

Affected products (as reported)

VendorProductVersions
backstage backstage < 1.50.5>= 1.51.0-next.0, < 1.54.6
@backstage plugin-techdocs-node < 1.14.6>= 1.15.0, < 1.15.4

Weakness: CWE-22, CWE-918 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N

References