Vulnerability · Published Oct 6, 2026 · Assigned by GitHub_M

CVE-2026-106503Backstage: Scaffolder action input authorization bypass

High 8.1

In plain English

A high-severity improper access control in backstage from backstage. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 42% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.1High
Exploit odds (30 days)0.5%top 57.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Backstage is an open framework for building developer portals. Prior to 3.3.1, 3.4.1, 4.0.3 and 4.1.0, the @backstage/plugin-scaffolder-backend package is affected by scaffolder action input authorization bypass. An authenticated user with access to affected Scaffolder templates could bypass configured action restrictions. Depending on integration credentials, this could grant unauthorized access to repositories and related source-control resources. This issue is fixed in versions 3.3.1, 3.4.1, 4.0.3 and 4.1.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@backstage/plugin-scaffolder-backend3.3.1GHSA-hmp2-4m7g-22cv
npm@backstage/plugin-scaffolder-backend3.4.1GHSA-hmp2-4m7g-22cv
npm@backstage/plugin-scaffolder-backend4.0.3GHSA-hmp2-4m7g-22cv
npm@backstage/plugin-scaffolder-backend4.1.0GHSA-hmp2-4m7g-22cv

Affected products (as reported)

VendorProductVersions
backstage backstage < 1.49.6>= 1.50.0-next.0, < 1.50.5>= 1.51.0-next.0, < 1.54.6
@backstage plugin-scaffolder-backend < 3.3.1>= 3.4.0, < 3.4.1>= 4.0.0, < 4.0.3>= 4.0.4, < 4.1.0

Weakness: CWE-178, CWE-284 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

References