Vulnerability · Published Oct 6, 2026 · Assigned by GitHub_M

CVE-2026-106498Backstage: Improper URL validation in catalog entity placeholder resolution

High 7.7

In plain English

A high-severity incorrect authorization in backstage from backstage. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 24% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.7High
Exploit odds (30 days)0.3%top 76.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Backstage is an open framework for building developer portals. Prior to 3.5.1, 3.6.2, 3.7.2, 3.8.2 and 3.9.1, the @backstage/plugin-catalog-backend package is affected by improper url validation in catalog entity placeholder resolution. An authenticated Backstage user could craft a catalog entity with placeholder directives that reference resources outside the entity's source repository. Under certain configurations, this could allow access to data not intended to be available to the user. This issue is fixed in versions 3.5.1, 3.6.2, 3.7.2, 3.8.2 and 3.9.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@backstage/plugin-catalog-backend3.9.1GHSA-qgvj-qcf8-xq73

Affected products (as reported)

VendorProductVersions
backstage backstage < 1.49.6>= 1.50.0-next.0, < 1.50.5>= 1.51.0-next.0, < 1.51.3>= 1.52.0-next.0, < 1.53.2>= 1.54.0-next.0, < 1.54.6
@backstage plugin-catalog-backend < 3.5.1>= 3.6.0, < 3.6.2>= 3.7.0, < 3.7.2>= 3.8.0, < 3.8.2>= 3.9.0, < 3.9.1

Weakness: CWE-863, CWE-918 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N

References