Vulnerability · Published Oct 6, 2026 · Assigned by GitHub_M
CVE-2026-106496Backstage: Inconsistent enforcement of allowed location types during catalog processing
Low 3.1
In plain English
A low-severity path traversal in backstage from backstage. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 16% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Backstage is an open framework for building developer portals. Prior to 3.9.1, the @backstage/plugin-catalog-backend package is affected by inconsistent enforcement of allowed location types during catalog processing. Under certain configurations, the catalog backend could process location types that were not intended to be allowed, potentially leading to unintended file access on the backend host. This issue is fixed in version 3.9.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @backstage/plugin-catalog-backend | 3.9.1 | GHSA-pcmq-25r3-5w9v |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| backstage | backstage | < 1.54.6 |
| @backstage | plugin-catalog-backend | < 3.9.1 |
Weakness: CWE-22, CWE-863 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N