Vulnerability · Published Oct 6, 2026 · Assigned by GitHub_M
CVE-2026-106491Backstage: Improper input validation in proxy-backend
Medium 6.4
In plain English
A medium-severity improper input validation in backstage from backstage. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 20% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Backstage is an open framework for building developer portals. Prior to 0.6.17, the @backstage/plugin-proxy-backend package is affected by improper input validation in proxy-backend. An authenticated Backstage user could craft a request URL that causes the proxy-backend to forward the request to a path outside the configured base path on the target server. This is limited to target servers already configured as proxy endpoints and requires Backstage authentication by default. This issue is fixed in version 0.6.17.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @backstage/plugin-proxy-backend | 0.6.17 | GHSA-9ghw-48h5-v2w5 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| backstage | backstage | < 1.54.6 |
| @backstage | plugin-proxy-backend | < 0.6.17 |
Weakness: CWE-20, CWE-22 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N