Vulnerability · Published Oct 6, 2026 · Assigned by GitHub_M

CVE-2026-106459Backstage: Improper input validation in Sentry scaffolder actions

High 8.5

In plain English

A high-severity information exposure in backstage from backstage. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 12% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.5High
Exploit odds (30 days)0.2%top 88.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Backstage is an open framework for building developer portals. From 0.3.0 until 0.3.8, the @backstage/plugin-scaffolder-backend-module-sentry package is affected by improper input validation in sentry scaffolder actions. An authenticated internal user who can execute the affected actions may cause the backend to contact unintended destinations and disclose Sentry integration credentials. Subsequent impact depends on network reachability and the privileges granted to the configured token. This issue is fixed in version 0.3.8.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@backstage/plugin-scaffolder-backend-module-sentry0.3.8GHSA-g734-fhp4-7mfp

Affected products (as reported)

VendorProductVersions
backstage backstage >= 1.47.0, < 1.54.8
@backstage plugin-scaffolder-backend-module-sentry >= 0.3.0, < 0.3.8

Weakness: CWE-200, CWE-918 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N

References