Vulnerability · Published Oct 6, 2026 · Assigned by GitHub_M
CVE-2026-106457Backstage: Insufficient audience validation in the Cloudflare Access auth provider
Medium 6.8
In plain English
A medium-severity improper authentication in backstage from backstage. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 29% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Backstage is an open framework for building developer portals. From 0.1.0 until 0.5.0, the @backstage/plugin-auth-backend-module-cloudflare-access-provider package is affected by insufficient audience validation in the cloudflare access auth provider. The Cloudflare Access auth provider verifies a token's signature and team issuer, but affected versions do not verify that the token was issued for the Backstage application. A user holding a valid token for another Access application in the same Cloudflare Zero Trust team may therefore be able to authenticate to Backstage if that token reaches the auth endpoint without the Backstage application's audience already being enforced upstream. Cloudflare Access normally evaluates the protected application before forwarding requests. This issue is fixed in version 0.5.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @backstage/plugin-auth-backend-module-cloudflare-access-provider | 0.5.0 | GHSA-q333-f498-w2x7 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| backstage | backstage | >= 1.26.0, < 1.55.0 |
| @backstage | plugin-auth-backend-module-cloudflare-access-provider | >= 0.1.0, < 0.5.0 |
Weakness: CWE-287 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N