Vulnerability · Published Oct 6, 2026 · Assigned by GitHub_M
CVE-2026-106456Backstage: Inconsistent credential enforcement for overlapping proxy routes
Medium 4.8
In plain English
A medium-severity incorrect authorization in backstage from backstage. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 15% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Backstage is an open framework for building developer portals. From 0.5.0 until 0.6.18, the @backstage/plugin-proxy-backend package is affected by inconsistent credential enforcement for overlapping proxy routes. An operator can configure overlapping proxy paths with different credential requirements. When a parent path permits unauthenticated access and a nested path requires credentials, the parent exemption can also cover requests handled by the nested proxy. An unauthenticated caller may therefore reach the nested upstream through Backstage, including with static upstream credentials configured for that proxy. This issue is fixed in version 0.6.18.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @backstage/plugin-proxy-backend | 0.6.18 | GHSA-472h-9c5j-prrr |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| backstage | backstage | >= 1.28.0, < 1.55.0 |
| @backstage | plugin-proxy-backend | >= 0.5.0, < 0.6.18 |
Weakness: CWE-863 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N