Vulnerability · Published Oct 6, 2026 · Assigned by GitHub_M

CVE-2026-106119LangChain: MongoDBChatMessageHistory query injection can allow cross-session access

Medium 6.0

In plain English

A medium-severity security flaw in mongodb from @langchain. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 40% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)6.0Medium
Exploit odds (30 days)0.5%top 59.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

LangChain is a framework for building LLM-powered applications. Prior to 1.3.1, MongoDBChatMessageHistory does not enforce the documented string type for an untrusted structured session identifier at runtime, allowing the identifier to be interpreted as a MongoDB query condition rather than as a literal value when multiple users' histories are stored in a shared MongoDB collection. An attacker able to invoke chat-history operations can read, modify, or delete another user's stored conversation. Applications using authenticated, server-controlled string identifiers are not affected. This issue is fixed in version 1.3.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@langchain/mongodb1.3.1GHSA-m6rx-h84q-8r95

Affected products (as reported)

VendorProductVersions
langchain-ai langchainjs < 1.5.14
@langchain mongodb < 1.3.1

Weakness: CWE-943 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N

References