Vulnerability · Published Oct 6, 2026 · Assigned by GitHub_M

CVE-2026-106100Payload: Field-level write access bypass in Payload on MongoDB

High 7.1

In plain English

A high-severity authorization bypass via user-controlled key in payload from payloadcms. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 12% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.1High
Exploit odds (30 days)0.2%top 88.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Payload is a free and open source headless content management system. In @payloadcms/db-mongodb versions before 3.87.0 and canary versions before 4.0.0-canary.20, an authenticated user who can update a document can modify fields that field-level write access control does not permit that user to change. The Postgres and SQLite adapters are not affected. This issue is fixed in versions 3.87.0 and 4.0.0-canary.20.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@payloadcms/db-mongodb3.87.0GHSA-4ww4-68q3-h7g5
npm@payloadcms/db-mongodb4.0.0-canary.20GHSA-4ww4-68q3-h7g5

Affected products (as reported)

VendorProductVersions
payloadcms payload < 3.87.0>= 4.0.0-canary.0, < 4.0.0-canary.20

Weakness: CWE-639, CWE-915 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N

References