Vulnerability · Published Oct 6, 2026 · Assigned by GitHub_M
CVE-2026-105864Payload: Cross-tenant create in @payloadcms/plugin-multi-tenant
Medium 5.3
In plain English
A medium-severity incorrect authorization in payload from payloadcms. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 9% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Payload is a free and open source headless content management system. In @payloadcms/plugin-multi-tenant versions before 3.90.0 and canary versions before 4.0.0-canary.34, an authenticated user limited to one tenant can create a record in another tenant when at least one tenant-enabled collection exists. Reads and direct edits of existing documents in the target tenant are not bypassed. This issue is fixed in versions 3.90.0 and 4.0.0-canary.34.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @payloadcms/plugin-multi-tenant | 3.90.0 | GHSA-xhm9-gwgw-3q2q |
| npm | @payloadcms/plugin-multi-tenant | 4.0.0-canary.34 | GHSA-xhm9-gwgw-3q2q |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| payloadcms | payload | < 3.90.0>= 4.0.0-canary.0, < 4.0.0-canary.34 |
| @payloadcms | plugin-multi-tenant | < 3.90.0>= 4.0.0-canary.0, < 4.0.0-canary.34 |
Weakness: CWE-863 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N