Vulnerability · Published Oct 6, 2026 · Assigned by GitHub_M
CVE-2026-105860Payload: Tenant authorization bypass in Multi-Tenant Plugin
High 7.1
In plain English
A high-severity missing authorization in payload from payloadcms. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 9% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Payload is a free and open source headless content management system. In @payloadcms/plugin-multi-tenant versions before 3.90.0 and canary versions before 4.0.0-canary.34, the default tenant array field access allows an authenticated user to assign the user's own account to other tenants. Deployments that replace the default behavior with secured tenants arrayFieldAccess.create and tenants arrayFieldAccess.update functions are not affected by this behavior. This issue is fixed in versions 3.90.0 and 4.0.0-canary.34.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @payloadcms/plugin-multi-tenant | 3.90.0 | GHSA-p96c-xwx8-3cqj |
| npm | @payloadcms/plugin-multi-tenant | 4.0.0-canary.34 | GHSA-p96c-xwx8-3cqj |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| payloadcms | payload | < 3.90.0>= 4.0.0-canary.0, < 4.0.0-canary.34 |
Weakness: CWE-862 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N