Vulnerability · Published Oct 6, 2026 · Assigned by GitHub_M
CVE-2026-105857Payload: RCE in Payload Form Builder
Critical 10.0
In plain English
A critical-severity code injection in payload from payloadcms. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 37% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Payload is a free and open source headless content management system. In @payloadcms/plugin-form-builder versions before 3.90.0 and canary versions before 4.0.0-canary.34, an attacker can craft a form submission that executes code remotely on the server. This issue is fixed in versions 3.90.0 and 4.0.0-canary.34.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @payloadcms/plugin-form-builder | 3.90.0 | GHSA-r488-j9vj-wx3q |
| npm | @payloadcms/plugin-form-builder | 4.0.0-canary.34 | GHSA-r488-j9vj-wx3q |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| payloadcms | payload | < 3.90.0>= 4.0.0-canary.0, < 4.0.0-canary.34 |
Weakness: CWE-94, CWE-1321 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H