Vulnerability · Published Oct 6, 2026 · Assigned by GitHub_M
CVE-2026-105845Payload: SQL Injection in SQLite and Postgres
Critical 9.8
In plain English
A critical-severity SQL injection in payload from payloadcms. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 32% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Payload is a free and open source headless content management system. In versions from 3.0.0 before 3.88.0 and canary versions before 4.0.0-canary.27, an untrusted user who can query readable collections through dynamic filters or joins can submit a request that causes SQL injection in the SQLite and Postgres adapters. This issue is fixed in versions 3.88.0 and 4.0.0-canary.27.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | payload | 3.88.0 | GHSA-v49j-62m6-pgrr |
| npm | payload | 4.0.0-canary.27 | GHSA-v49j-62m6-pgrr |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| payloadcms | payload | >= 3.0.0, < 3.88.0>= 4.0.0-canary.0, < 4.0.0-canary.27 |
Weakness: CWE-89 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H