Vulnerability · Published Oct 6, 2026 · Assigned by GitHub_M
CVE-2026-105804Payload: Password hashes use insufficient PBKDF2 iterations
Medium 5.7
In plain English
A medium-severity security flaw in payload from payloadcms. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 0% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Payload is a free and open source headless content management system. Payload versions from 3.0.0 before 3.90.0 and canary versions from 4.0.0-canary.0 before 4.0.0-canary.34 use a lower-than-recommended PBKDF2 work factor for password hashing, reducing the computational effort required to test recovered password hashes. This issue is fixed in versions 3.90.0 and 4.0.0-canary.34.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | payload | 3.90.0 | GHSA-q6mq-ch85-c8mm |
| npm | payload | 4.0.0-canary.34 | GHSA-q6mq-ch85-c8mm |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| payloadcms | payload | >= 3.0.0, < 3.90.0>= 4.0.0-canary.0, < 4.0.0-canary.34 |
Weakness: CWE-916 · Vector: CVSS:4.0/AV:L/AC:H/AT:P/PR:H/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N