Vulnerability · Published Oct 5, 2026 · Assigned by GitHub_M

CVE-2026-105782Scrapy: Arbitrary Module Import via Referrer-Policy Header in RefererMiddleware

High 7.5

In plain English

A high-severity security flaw in scrapy from scrapy. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 32% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.4%top 68.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Scrapy is a high-level web crawling and scraping framework for Python. From 1.4.0 until 2.14.2, RefererMiddleware in scrapy/spidermiddlewares/referer.py treated a Referrer-Policy response-header value that resembled a Python import path as a referrer policy class, imported the referenced object, and called it. A malicious website could supply a callable such as sys.exit and terminate a crawler processing the response. This issue is fixed in version 2.14.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12python-scrapyno fix listedDEBIAN-CVE-2026-105782
Debian:13python-scrapyno fix listedDEBIAN-CVE-2026-105782
Debian:14python-scrapy2.14.2-1DEBIAN-CVE-2026-105782
PyPIscrapy2.14.2GHSA-cwxj-rr6w-m6w7
PyPIscrapy2.14.2PYSEC-2026-4299
Ubuntu:26.04:LTSpython-scrapyno fix listedUBUNTU-CVE-2026-105782

Affected products (as reported)

VendorProductVersions
scrapy scrapy >= 1.4.0, < 2.14.2

Weakness: CWE-470 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References