Vulnerability · Published Oct 5, 2026 · Assigned by chainguard
CVE-2026-105768apko /etc/passwd and /etc/group UID/GID truncation writes package-supplied entries as root
Medium 6.3
In plain English
A medium-severity security flaw in apko from chainguard-dev. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 23% of all known vulnerabilities).
Official description
apko allows users to build and publish OCI container images built from apk packages. From version 0.2.0 to before version 1.4.5, UserEntry.Parse and GroupEntry.Parse in pkg/passwd read the UID and GID fields of /etc/passwd and /etc/group entries with strconv.Atoi and convert them to uint32 without a range check. On 64-bit platforms an out-of-range value such as 4294967296 (2^32) is truncated to 0, and negative values wrap. Because apko parses the passwd and group entries supplied by the packages it installs and writes them back into the image, an attacker who controls a package installed into the image can ship an entry that appears to declare an unprivileged UID or GID but is written into the built image as UID 0 or GID 0 (root). The truncated UID is also used when resolving the image's run-as user. This issue has been fixed in version 1.4.5.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| chainguard-dev | apko | 0.2.0 – before 1.4.5 |
Weakness: CWE-197 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:L/SA:N
References
- GHSA-rj6x-hwpv-vhvf vendor-advisory
- chainguard-dev/apko#2516 patch
- Fix commit 739e7ce patch
- apko v1.4.5 release-notes