Vulnerability · Published Oct 5, 2026 · Assigned by GitHub_M
CVE-2026-105756vLLM: Loose `cache_salt` validation lets a single request kill EngineCore on LMCache-MP deployments — uncaught downstream `ValueError` denial of service
Medium 6.5
In plain English
A medium-severity improper input validation in vllm from vllm-project. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 26% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
vLLM is an inference and serving engine for large language models. Prior to 0.30.0, OpenAI-compatible request models accept a non-empty cache_salt value without enforcing the character and length restrictions required by the IPCCacheServerKey consumer in LMCache-MP. On deployments using the LMCache-MP connector, a salt that contains a forbidden character or exceeds the permitted length can raise an uncaught ValueError during scheduler cache lookup, causing EngineCore to terminate and denying service to all concurrent users. This issue is fixed in version 0.30.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | vllm | 0.30.0 | GHSA-2823-qmq8-rwvj |
| PyPI | vllm | 0.30.0 | PYSEC-2026-4306 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| vllm-project | vllm | < 0.30.0 |
Weakness: CWE-20, CWE-248 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
References
- https://github.com/vllm-project/vllm/security/advisories/GHSA-2823-qmq8-rwvj x_refsource_CONFIRM
- https://github.com/vllm-project/vllm/pull/51444 x_refsource_MISC
- https://github.com/vllm-project/vllm/commit/e962733e08d10f7ca65dac4df99e116460b8b174 x_refsource_MISC
- https://github.com/vllm-project/vllm/releases/tag/v0.30.0 x_refsource_MISC