Vulnerability · Published Oct 5, 2026 · Assigned by GitHub_M
CVE-2026-105698Langflow: Cross-user flow access and vertex execution via deprecated /api/v1/build/{flow_id}/vertices endpoints
Medium 5.4
In plain English
A medium-severity authorization bypass via user-controlled key in langflow from langflow-ai. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 13% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Langflow is a tool for building and deploying AI-powered agents and workflows. From 1.0.0 until 1.10.1, Langflow did not verify flow ownership in the deprecated POST /api/v1/build/{flow_id}/vertices and POST /api/v1/build/{flow_id}/vertices/{vertex_id} handlers. Through version 1.7.1, an unauthenticated caller who knew another user's flow UUID could reach these handlers; from version 1.7.2 through 1.10.0, callers had to authenticate but needed no elevated privileges. Such a caller could cause retrieve_vertices_order to load and cache the private graph, enumerate its vertex identifiers, and use build_vertex to execute selected vertices and receive their results. build_graph_from_db_no_cache performed a primary-key lookup without an owner filter. This could disclose private flow structure, configured values, and selected outputs and could trigger victim-configured side effects and build-history records, although it did not expose the victim's variable-store credentials or permit modification of the stored flow. This issue is fixed in Langflow 1.10.1 and langflow-base 0.10.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | langflow | 1.10.1 | GHSA-gh98-4phw-6fmw |
| PyPI | langflow | 1.10.1 | PYSEC-2026-4234 |
| PyPI | langflow-base | 0.10.1 | GHSA-gh98-4phw-6fmw |
| PyPI | langflow-base | 0.10.1 | PYSEC-2026-4238 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| langflow-ai | langflow | >= 1.0.0, < 1.10.1 |
| langflow-ai | langflow-base | < 0.10.1 |
Weakness: CWE-639, CWE-862 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
References
- https://github.com/langflow-ai/langflow/security/advisories/GHSA-gh98-4phw-6fmw x_refsource_CONFIRM
- https://github.com/langflow-ai/langflow/pull/13153 x_refsource_MISC
- https://github.com/langflow-ai/langflow/commit/fb3d6ec90b1e4d52eaa40915a64b1f86b6542f55 x_refsource_MISC
- https://github.com/langflow-ai/langflow/releases/tag/v1.10.1 x_refsource_MISC