Vulnerability · Published Oct 5, 2026 · Assigned by GitHub_M

CVE-2026-105697Langflow: OS command injection (RCE) via arbitrary command in MCP stdio server configuration

Critical 9.9

In plain English

A critical-severity OS command injection in langflow from langflow-ai. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 61% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)9.9Critical
Exploit odds (30 days)0.9%top 38.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

Langflow is a tool for building and deploying AI-powered agents and workflows. Before Langflow 1.10.3, the MCP stdio transport launched whatever command / args a user put in an MCP server configuration, with no allowlist and (before 1.10.3) wrapped in bash -c "exec {command} ...". Any user able to reach the MCP server settings ("Settings → MCP Servers → Add MCP Server", POST/PATCH /api/v2/mcp/servers/{server_name}) or to build a flow with the MCP Tools component could add a "server" whose command is an arbitrary OS command (touch, rm -rf, a reverse shell, ...). The command runs on the Langflow host as the Langflow process user as soon as Langflow tries to connect to the server (listing servers, loading tools, running the flow) — even when the UI then reports that the stdio server failed to start. With the default LANGFLOW_AUTO_LOGIN=true, GET /api/v1/auto_login hands out a token without credentials, so on an exposed instance running the default configuration this is reachable without an account. AUTO_LOGIN is documented as a development-only setting; with it disabled, any authenticated (non-admin) user can exploit it. This issue is fixed in Langflow 1.10.3, langflow-base 0.10.3, and lfx 1.10.3.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIlangflow1.10.3GHSA-w794-rj3p-xv45
PyPIlangflow1.10.3PYSEC-2026-4237
PyPIlangflow-base0.10.3GHSA-w794-rj3p-xv45
PyPIlangflow-base0.10.3PYSEC-2026-4239
PyPIlfx1.10.3GHSA-w794-rj3p-xv45
PyPIlfx1.10.3PYSEC-2026-4241

Affected products (as reported)

VendorProductVersions
langflow-ai langflow >= 1.1.2, < 1.10.3
langflow-ai langflow-base >= 0.1.2, < 0.10.3
langflow-ai lfx < 1.10.3

Weakness: CWE-78 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

References