Vulnerability · Published Oct 5, 2026 · Assigned by GitHub_M

CVE-2026-105643Ghost: Stored XSS via Embed Card Previews

High 7.3

In plain English

A high-severity cross-site scripting in Ghost from TryGhost. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 20% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.3High
Exploit odds (30 days)0.3%top 79.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Ghost is a Node.js content management system. From version 6.34.0 until 6.67.0, embed cards in the Ghost editor could bypass protections against stored cross-site scripting. Any staff user, including Contributors, could store scripts in post content that ran when another staff user opened the post in the editor, potentially compromising that user’s admin session. Self-hosted sites should leave the new  security.embedPreviewUrl  configuration option at its default value. This issue is fixed in version 6.67.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmghost6.67.0GHSA-69qc-f5m6-889c

Affected products (as reported)

VendorProductVersions
TryGhost Ghost >= 6.34.0, < 6.67.0

Weakness: CWE-79, CWE-653 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N

References