Vulnerability · Published Oct 28, 2026 · Assigned by PostgreSQL
CVE-2026-105612PostgreSQL Anonymizer: Data-modifying CTEs bypass the read-only restriction of masked roles
Low 3.5
In plain English
A low-severity missing authorization in PostgreSQL Anonymizer from DALIBO. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 6% of all known vulnerabilities).
Severity (CVSS 3.1)3.5Low
Exploit odds (30 days)0.2%top 94.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
PostgreSQL Anonymizer contains a vulnerability that data-modifying CTEs to bypass the read-only restriction of masked roles. The problem is resolved in PostgreSQL Anonymizer 3.3.0 and later versions
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| DALIBO | PostgreSQL Anonymizer | 1 – before 3.3.0 |
Weakness: CWE-862 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N