Vulnerability · Published Oct 2, 2026 · Assigned by GitHub_M

CVE-2026-104844PostCSS: Quadratic complexity in flat selector parsing allows CPU exhaustion

Medium 5.9

In plain English

A medium-severity uncontrolled resource consumption in postcss-selector-parser from postcss. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 33% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.9Medium
Exploit odds (30 days)0.4%top 66.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

PostCSS Selector Parser is a CSS selector parser that integrates with PostCSS but does not require it. Prior to 7.1.6, src/parser.js splitWord() can receive a flat selector as one word token carrying many class or ID indexes because period and hash characters are not tokenizer word delimiters. The uniqs() deduplication and per-index class and ID membership checks repeatedly scan the class and ID index arrays, while a separate Sass-interpolation filtering pass also performs repeated linear scanning. Together, these passes make parsing quadratic in the number of indexes and allow a crafted selector to occupy a synchronous parser thread. The maxNestingDepth guard does not mitigate the issue because the hostile selector can have zero nesting depth. Only consumers that synchronously parse untrusted selectors in an exposed request path are affected; ordinary build-time parsing of trusted sources is not affected. This issue is fixed in version 7.1.6.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmpostcss-selector-parser7.1.6GHSA-rj75-hqrm-r3gf
npmpostcss-selector-parser6.1.5GHSA-rj75-hqrm-r3gf

Affected products (as reported)

VendorProductVersions
postcss postcss-selector-parser < 7.1.6

Weakness: CWE-400, CWE-407 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

References