Vulnerability · Published Nov 5, 2026 · Assigned by GitHub_M
CVE-2026-104269ModSecurity: RFC 2231 `filename*` Parameter Bypasses Multipart Filename Rules on RFC-Compliant Backends (Go, Python, Node, Java)
High 8.6
In plain English
A high-severity security flaw in ModSecurity from owasp-modsecurity. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 47% of all known vulnerabilities).
Official description
ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. From 3.0.0 until 3.0.17, ModSecurity's multipart parser does not apply the RFC 2231 filename* parameter precedence used by common Go, Python, Node.js, and Java application parsers. A Content-Disposition header can provide a benign filename parameter for ModSecurity and a different encoded filename* value that the backend prefers, causing MULTIPART_FILENAME rules and the application to make security decisions on different names. Applications that use the backend-selected name for storage, extension checks, or content-type inference can therefore receive a filename that bypassed WAF inspection. PHP's native multipart parser is not affected by this discrepancy. This issue is fixed in version 3.0.17.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | modsecurity | no fix listed | DEBIAN-CVE-2026-104269 |
| Debian:13 | modsecurity | no fix listed | DEBIAN-CVE-2026-104269 |
| Debian:14 | modsecurity | no fix listed | DEBIAN-CVE-2026-104269 |
| Debian:12 | modsecurity-apache | no fix listed | DEBIAN-CVE-2026-104269 |
| Debian:13 | modsecurity-apache | no fix listed | DEBIAN-CVE-2026-104269 |
| Debian:14 | modsecurity-apache | no fix listed | DEBIAN-CVE-2026-104269 |
| Ubuntu:22.04:LTS | modsecurity | no fix listed | UBUNTU-CVE-2026-104269 |
| Ubuntu:24.04:LTS | modsecurity | no fix listed | UBUNTU-CVE-2026-104269 |
| Ubuntu:26.04:LTS | modsecurity | no fix listed | UBUNTU-CVE-2026-104269 |
| Ubuntu:26.10 | modsecurity | no fix listed | UBUNTU-CVE-2026-104269 |
| Ubuntu:26.04:LTS | modsecurity-apache | no fix listed | UBUNTU-CVE-2026-104269 |
| Ubuntu:26.10 | modsecurity-apache | no fix listed | UBUNTU-CVE-2026-104269 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| owasp-modsecurity | ModSecurity | >= 3.0.0, < 3.0.17 |
Weakness: CWE-436 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N
References
- https://github.com/owasp-modsecurity/ModSecurity/security/advisories/GHSA-5pww-8rfg-9crf x_refsource_CONFIRM
- https://github.com/owasp-modsecurity/ModSecurity/commit/463db0c840fa27bfba095b0406a63004a12884b0 x_refsource_MISC
- https://github.com/owasp-modsecurity/ModSecurity/commit/c6bd53d2dd96766b3afdc35d9929ebb20925d13d x_refsource_MISC
- https://github.com/owasp-modsecurity/ModSecurity/releases/tag/v2.9.15 x_refsource_MISC
- https://github.com/owasp-modsecurity/ModSecurity/releases/tag/v3.0.17 x_refsource_MISC