Vulnerability · Published Oct 2, 2026 · Assigned by apache
CVE-2026-103880Apache Directory LDAP API: Denial of service via excessive bcrypt cost factor in stored passwords
High 7.5
In plain English
A high-severity security flaw in Apache Directory LDAP API from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 38% of all known vulnerabilities).
Official description
Asymmetric Resource Consumption vulnerability in Apache Directory LDAP API. Storing a password using the bcrypt algorithm with a high force like 30 in a LDAP server that supports this algorithm will cause the server CPU to run for hours checking the credentials. A bounded cost should be enforced to avoid a server DOS. This issue affects Apache Directory LDAP API: from 2.1.0 before 2.1.9. Users are recommended to upgrade to version 2.1.9, which fixes the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | apache-directory-api | no fix listed | DEBIAN-CVE-2026-103880 |
| Debian:13 | apache-directory-api | no fix listed | DEBIAN-CVE-2026-103880 |
| Debian:14 | apache-directory-api | no fix listed | DEBIAN-CVE-2026-103880 |
| Ubuntu:22.04:LTS | apache-directory-api | no fix listed | UBUNTU-CVE-2026-103880 |
| Ubuntu:24.04:LTS | apache-directory-api | no fix listed | UBUNTU-CVE-2026-103880 |
| Ubuntu:26.04:LTS | apache-directory-api | no fix listed | UBUNTU-CVE-2026-103880 |
| Ubuntu:26.10 | apache-directory-api | no fix listed | UBUNTU-CVE-2026-103880 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Directory LDAP API | 2.1.0 – before 2.1.9 |
Weakness: CWE-405 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H