Vulnerability · Published Oct 2, 2026 · Assigned by apache
CVE-2026-103877Apache Directory LDAP API: Unsafe loading of Java code from LDAP schema elements
Critical 9.8
In plain English
A critical-severity unsafe deserialization in Apache Directory LDAP API from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 41% of all known vulnerabilities).
Official description
Deserialization of Untrusted Data vulnerability in Apache Directory LDAP API. A rogue/compromised LDAP server (or pre-TLS MITM) can answer a client's loadSchema() subschema search with a schema object that contains a serialized Java class, allowing some potential RCE. This issue affects Apache Directory LDAP API: from 2.1.0 before 2.1.9. Users are recommended to upgrade to version 2.1.9, which fixes the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | apache-directory-api | no fix listed | DEBIAN-CVE-2026-103877 |
| Debian:13 | apache-directory-api | no fix listed | DEBIAN-CVE-2026-103877 |
| Debian:14 | apache-directory-api | no fix listed | DEBIAN-CVE-2026-103877 |
| Ubuntu:22.04:LTS | apache-directory-api | no fix listed | UBUNTU-CVE-2026-103877 |
| Ubuntu:24.04:LTS | apache-directory-api | no fix listed | UBUNTU-CVE-2026-103877 |
| Ubuntu:26.04:LTS | apache-directory-api | no fix listed | UBUNTU-CVE-2026-103877 |
| Ubuntu:26.10 | apache-directory-api | no fix listed | UBUNTU-CVE-2026-103877 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Directory LDAP API | 2.1.0 – before 2.1.9 |
Weakness: CWE-502 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H