Vulnerability · Published Oct 2, 2026 · Assigned by apache
CVE-2026-103552Apache Directory LDAP API: A unbound client can send a deeply nested search filter that overflows the stack in the server's decoder
High 7.3
In plain English
A high-severity stack buffer overflow in Apache Directory LDAP API from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 26% of all known vulnerabilities).
Severity (CVSS 3.1)7.3High
Exploit odds (30 days)0.3%top 74.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
Stack Overflow vulnerability in Apache Directory LDAP API. Before binding, a client can send a deeply nested search filter that overflows the stack in the server's decoder. This issue affects Apache Directory LDAP API: from 1.2.0 before 1.2.9. Users are recommended to upgrade to version 1.2.9, which fixes the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | apache-directory-api | no fix listed | DEBIAN-CVE-2026-103552 |
| Debian:13 | apache-directory-api | no fix listed | DEBIAN-CVE-2026-103552 |
| Debian:14 | apache-directory-api | no fix listed | DEBIAN-CVE-2026-103552 |
| Ubuntu:22.04:LTS | apache-directory-api | no fix listed | UBUNTU-CVE-2026-103552 |
| Ubuntu:24.04:LTS | apache-directory-api | no fix listed | UBUNTU-CVE-2026-103552 |
| Ubuntu:26.04:LTS | apache-directory-api | no fix listed | UBUNTU-CVE-2026-103552 |
| Ubuntu:26.10 | apache-directory-api | no fix listed | UBUNTU-CVE-2026-103552 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Directory LDAP API | 1.2.0 – before 1.2.9 |
Weakness: CWE-121 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L