Vulnerability · Published Sep 30, 2026 · Assigned by VulDB

CVE-2026-103241vllm-project vLLM Gemma4UnifiedParser gemma4.rs denial of service

Medium 5.3

In plain English

A medium-severity security flaw in vLLM from vllm-project. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 54% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.3Medium
Exploit odds (30 days)0.7%top 46.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

A flaw has been found in vllm-project vLLM up to 0.26.0. This vulnerability affects unknown code of the file rust/src/parser/src/unified/gemma4.rs of the component Gemma4UnifiedParser. Executing a manipulation can lead to denial of service. The attack may be launched remotely. The exploit has been published and may be used. Upgrading to version 0.29.1rc0 is able to resolve this issue. This patch is called 3439bad37e68ba9755a46f4f6b44a4aeaf1f60a9. Upgrading the affected component is advised.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIvllm0.27.0PYSEC-2026-4186

Affected products (as reported)

VendorProductVersions
vllm-project vLLM 0.10.20.30.40.50.60.70.8

Weakness: CWE-404 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L/E:P/RL:O/RC:C

References