Vulnerability · Published Sep 29, 2026 · Assigned by GitHub_M

CVE-2026-102904JupyterLab: Argument injection in JupyterLab extension uninstall exposes server-readable files and internal URLs

Medium 5.4

In plain English

A medium-severity argument injection in jupyterlab from jupyterlab. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 11% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.4Medium
Exploit odds (30 days)0.2%top 89.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

JupyterLab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook Architecture. From JupyterLab 4.0.0 until 4.5.11 and 4.6.4, the PyPI Extension Manager uninstall request reaches ExtensionHandler.post, which validates extension names for installation but passes uninstall names to PyPIExtensionManager.uninstall and python -m pip uninstall without rejecting option-like values. The security impact requires that the PyPI Extension Manager is enabled, the account can call the extension API, and kernels and terminals are disabled or delegated to remote hosts; otherwise the user can already read files and make outbound requests directly. An authenticated user with extension API access can supply a pip requirements option to make the server read a local file or fetch an internal URL, and reflected parse errors can return the first unparsable line or response content. A pip log option can also create or corrupt a chosen path with pip-generated log text, but the requester cannot select an arbitrary disclosed line or arbitrary file content, and the injection does not add code execution or availability impact beyond ordinary package removal. This issue is fixed in JupyterLab 4.5.11 and 4.6.4.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:13jupyterlabno fix listedDEBIAN-CVE-2026-102904
Debian:14jupyterlabno fix listedDEBIAN-CVE-2026-102904
PyPIjupyterlab4.5.11GHSA-3325-v43h-43rv
PyPIjupyterlab4.5.11, 4.6.4PYSEC-2026-4055
PyPIjupyterlab4.6.4GHSA-3325-v43h-43rv
Ubuntu:26.04:LTSjupyterlabno fix listedUBUNTU-CVE-2026-102904
Ubuntu:26.10jupyterlabno fix listedUBUNTU-CVE-2026-102904

Affected products (as reported)

VendorProductVersions
jupyterlab jupyterlab >= 4.0.0, < 4.5.11>= 4.6.0, < 4.6.4

Weakness: CWE-88, CWE-209, CWE-918 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N

References