Vulnerability · Published Oct 13, 2026 · Assigned by GitHub_M
CVE-2026-102832JupyterLab: Command link trust prompt in JupyterLab can trust a document other than the one clicked
Medium 4.2
In plain English
A medium-severity incorrect authorization in jupyterlab from jupyterlab. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 4% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
JupyterLab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook Architecture. From 4.5.7 until 4.5.11 and 4.6.4, the markdownviewer:trust and notebook:trust command-link handlers use tracker.currentWidget to resolve the current Markdown viewer or notebook when the user answers rather than retaining the document whose command button was clicked. If another document becomes current while the prompt is open and the user chooses Trust, JupyterLab marks the second document trusted while leaving the clicked document untrusted. Later command buttons in the incorrectly trusted document run without a prompt, and trusting a notebook marks all cells trusted, saves unsaved edits, and persists the server signature to disk. Applications that bundle JupyterLab, including affected Notebook and JupyterLite releases, inherit the behavior. This issue is fixed in versions 4.5.11 and 4.6.4.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | jupyterlab | 4.6.4 | GHSA-jwrc-gm9j-263p |
| PyPI | jupyterlab | 4.5.11 | GHSA-jwrc-gm9j-263p |
| PyPI | jupyterlite-core | 0.8.4 | GHSA-jwrc-gm9j-263p |
| PyPI | notebook | 7.6.3 | GHSA-jwrc-gm9j-263p |
| Ubuntu:26.04:LTS | jupyterlab | no fix listed | UBUNTU-CVE-2026-102832 |
| Ubuntu:26.10 | jupyterlab | no fix listed | UBUNTU-CVE-2026-102832 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| jupyterlab | jupyterlab | >= 4.5.7, < 4.5.11>= 4.6.0, < 4.6.4 |
| jupyterlab | jupyterlite-core | >= 0.7.5, < 0.8.4 |
| jupyterlab | notebook | >= 7.5.6, < 7.6.3 |
Weakness: CWE-367, CWE-863 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N
References
- https://github.com/jupyterlab/jupyterlab/security/advisories/GHSA-jwrc-gm9j-263p x_refsource_CONFIRM
- https://github.com/jupyterlab/jupyterlab/commit/0fc18ab4ef67e431a8f6560e387193baf786c70a x_refsource_MISC
- https://github.com/jupyterlab/jupyterlab/commit/b64bc88b8ca034cf158604a5cc48ca9170ea453b x_refsource_MISC
- https://github.com/jupyterlab/jupyterlab/commit/f7e5f9803fdf2aaaa0e9bfb9cc73386a8cc5f0b2 x_refsource_MISC
- https://github.com/jupyterlab/jupyterlab/releases/tag/v4.5.11 x_refsource_MISC
- https://github.com/jupyterlab/jupyterlab/releases/tag/v4.6.4 x_refsource_MISC