Vulnerability · Published Sep 29, 2026 · Assigned by GitHub_M

CVE-2026-102831JupyterLab: Cross-site scripting (XSS) in JupyterLab via notebook cells pasted from the system clipboard

High 8.1

In plain English

A high-severity cross-site scripting in jupyterlab from jupyterlab. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 15% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.1High
Exploit odds (30 days)0.2%top 85.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

JupyterLab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook Architecture. From JupyterLab 4.5.0 until 4.5.11 and 4.6.4, from Notebook 7.5.0 until 7.6.3, and from JupyterLite Core 0.7.0 until 0.8.4, the system clipboard cell-paste path accepts attacker-controlled cell JSON without clearing metadata.trusted. When useSystemClipboardForCells is active and pasteCodeCellsWithoutOutput is disabled, a pasted code cell can mark HTML output as trusted, bypass output sanitization, and execute script in the authenticated JupyterLab origin without executing the cell. Markdown and raw cells are not affected because their output is sanitized. This issue is fixed in JupyterLab 4.5.11 and 4.6.4, Notebook 7.6.3, and JupyterLite Core 0.8.4.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12jupyter-notebookno fix listedDEBIAN-CVE-2026-102831
Debian:13jupyter-notebookno fix listedDEBIAN-CVE-2026-102831
Debian:14jupyter-notebookno fix listedDEBIAN-CVE-2026-102831
PyPIjupyterlab4.5.11GHSA-6966-vjj6-99xv
PyPIjupyterlab4.5.11, 4.6.4PYSEC-2026-4057
PyPIjupyterlab4.6.4GHSA-6966-vjj6-99xv
PyPIjupyterlite0.8.4PYSEC-2026-4058
PyPIjupyterlite0.8.4GHSA-6966-vjj6-99xv
PyPIjupyterlite-core0.8.4PYSEC-2026-4060
PyPIjupyterlite-core0.8.4GHSA-6966-vjj6-99xv
PyPInotebook7.6.3PYSEC-2026-4112
PyPInotebook7.6.3GHSA-6966-vjj6-99xv
Ubuntu:26.04:LTSjupyter-notebookno fix listedUBUNTU-CVE-2026-102831
Ubuntu:26.10jupyter-notebookno fix listedUBUNTU-CVE-2026-102831
Ubuntu:26.04:LTSjupyterlabno fix listedUBUNTU-CVE-2026-102831
Ubuntu:26.10jupyterlabno fix listedUBUNTU-CVE-2026-102831

Affected products (as reported)

VendorProductVersions
jupyterlab jupyterlab >= 4.5.0, < 4.5.11>= 4.6.0, < 4.6.4
jupyterlab notebook >= 7.5.0, < 7.6.3
jupyterlab jupyterlite-core >= 0.7.0, < 0.8.4

Weakness: CWE-79, CWE-345 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N

References