Vulnerability · Published Sep 29, 2026 · Assigned by GitHub_M

CVE-2026-102830JupyterLab: Cross-site scripting (XSS) in JupyterLab via crafted language package (jupyterlab.json)

Medium 6.8

In plain English

A medium-severity cross-site scripting in jupyterlab from jupyterlab. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 18% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.8Medium
Exploit odds (30 days)0.3%top 82.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

JupyterLab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook Architecture. From JupyterLab 3.0.0 until 4.5.11 and 4.6.4, and in JupyterLite Core 0.8.3 and earlier, the Plural-Forms header in a selected third-party language pack can append JavaScript after a valid plural rule because prefix-only regular-expression validation accepts a matching prefix without requiring the entire header to match. JupyterLab passes the accepted expression to new Function, so loading the catalogue and translating a plural string executes the appended code in the authenticated JupyterLab origin. Where Jupyter Server kernels, terminals, and APIs are exposed, the code can use authenticated server APIs to read or modify files and run code. Impact is much more limited in JupyterLite because it typically lacks most exposed Jupyter Server surfaces. The default English locale is unaffected because it does not load a translation catalogue. This issue is fixed in JupyterLab 4.5.11 and 4.6.4 and JupyterLite Core 0.8.4.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:13jupyterlabno fix listedDEBIAN-CVE-2026-102830
Debian:14jupyterlabno fix listedDEBIAN-CVE-2026-102830
PyPIjupyterlab4.5.11GHSA-3jqq-pw4j-pqcj
PyPIjupyterlab4.5.11, 4.6.4PYSEC-2026-4056
PyPIjupyterlab4.6.4GHSA-3jqq-pw4j-pqcj
PyPIjupyterlite-core0.8.4PYSEC-2026-4059
PyPIjupyterlite-core0.8.4GHSA-3jqq-pw4j-pqcj
Ubuntu:26.04:LTSjupyterlabno fix listedUBUNTU-CVE-2026-102830
Ubuntu:26.10jupyterlabno fix listedUBUNTU-CVE-2026-102830

Affected products (as reported)

VendorProductVersions
jupyterlab jupyterlab >= 3.0.0, < 4.5.11>= 4.6.0, < 4.6.4
jupyterlab jupyterlite-core < 0.8.4

Weakness: CWE-79, CWE-94 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N

References