Vulnerability · Published Sep 29, 2026 · Assigned by GitHub_M

CVE-2026-102828simple-git unsafe-operation guard does not block trailer command configuration

Critical 9.2

In plain English

A critical-severity OS command injection in git-js from steveukx. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 31% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)9.2Critical
Exploit odds (30 days)0.4%top 68.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

simple-git, an interface for running git commands in any node.js application, enables applications to execute Git operations from JavaScript. From 3.15.0 until 4.0.1, the default blockUnsafeOperationsPlugin does not classify trailer.<token>.cmd as unsafe configuration. An application that passes attacker-controlled values through SimpleGitOptions.config or inline -c arguments can therefore allow Git to invoke an attacker-selected shell command when git interpret-trailers processes the configured trailer. The command executes with the operating-system identity and permissions of the Node.js process. This issue is fixed in 4.0.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmsimple-git4.0.1GHSA-x6jw-m9v5-85vh

Affected products (as reported)

VendorProductVersions
steveukx git-js >= 3.15.0, < 4.0.1

Weakness: CWE-78, CWE-184 · Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

References