Vulnerability · Published Jun 1, 2026 · Assigned by VulDB
CVE-2026-10269decolua 9router HTTP Header dashboardGuard.js isAuthenticated improper authorization
Medium 6.3
In plain English
A medium-severity security flaw in 9router from decolua. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 20% of all known vulnerabilities).
Official description
A security vulnerability has been detected in decolua 9router up to 0.4.0. This issue affects the function isAuthenticated of the file src/dashboardGuard.js of the component HTTP Header Handler. The manipulation of the argument Host leads to improper authorization. The attack is possible to be carried out remotely. Upgrading to version 0.4.1 is capable of addressing this issue. The identifier of the patch is 428e2c045cb9c0eb8080e8b580471a9c2eaa95ca. Upgrading the affected component is recommended.
Affected products (as reported)
Weakness: CWE-285, CWE-266 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L/E:X/RL:O/RC:C
References
- VDB-367548 | decolua 9router HTTP Header dashboardGuard.js isAuthenticated improper authorization vdb-entry, technical-description
- VDB-367548 | CTI Indicators (IOB, IOC, TTP, IOA) signature, permissions-required
- CVE-2026-10269 | CVE Analysis and Report third-party-advisory
- Submit #825188 | decolua 9router >= 0.2.72, < 0.4.1 Origin Validation Error third-party-advisory
- https://github.com/decolua/9router/issues/742 issue-tracking
- https://github.com/decolua/9router/commit/428e2c045cb9c0eb8080e8b580471a9c2eaa95ca patch
- https://github.com/decolua/9router/releases/tag/v0.4.1 patch
- https://github.com/decolua/9router/ product