Vulnerability · Published Oct 13, 2026 · Assigned by GitHub_M

CVE-2026-102603Gotify: Insufficiently Protected Password Change endpoint

Medium 5.3

In plain English

A medium-severity security flaw in server from gotify. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 27% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)5.3Medium
Exploit odds (30 days)0.3%top 73.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Gotify server is a simple server for sending and receiving messages in real-time per WebSocket. Prior to 3.0.0, the password change endpoint (POST /current/user/password) accepts a valid client token without requiring the account's current password or another elevated authentication step. An attacker who obtains a client token can set a new password for the associated user, taking control of password authentication and forcing account recovery through an administrator or direct database access. This issue is fixed in version 3.0.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Gogithub.com/gotify/serverno fix listedGO-2026-6772
Gogithub.com/gotify/server/v2no fix listedGHSA-3hcj-9m7p-wwm9
Gogithub.com/gotify/server/v2no fix listedGO-2026-6772
Gogithub.com/gotify/server/v33.0.0GHSA-3hcj-9m7p-wwm9
Gogithub.com/gotify/server/v33.0.0GO-2026-6772

Affected products (as reported)

VendorProductVersions
gotify server < 3.0.0

Weakness: CWE-620 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N

References