Vulnerability · Published Oct 20, 2026 · Assigned by apache

CVE-2026-101296Apache Tomcat: JNDIRealm bind credential validation fails open for non-GSSAPI SASL mechanisms

Critical 9.1

In plain English

A critical-severity security flaw in Apache Tomcat from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 50% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)9.1Critical
Exploit odds (30 days)0.6%top 49.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

A missing critical step in authentication vulnerability in Apache Tomcat when the JNDI realm was configured with with a non GSSAPI SASL authentication mechanism allowed attackers to authenticate without providing the correct password. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.26, from 10.1.0-M1 through 10.1.60, from 9.0.0.M1 through 9.0.122. The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.27, 10.1.61 or 9.0.123, which fix the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12tomcat10no fix listedDEBIAN-CVE-2026-101296
Debian:13tomcat10no fix listedDEBIAN-CVE-2026-101296
Debian:14tomcat10no fix listedDEBIAN-CVE-2026-101296
Debian:13tomcat11no fix listedDEBIAN-CVE-2026-101296
Debian:14tomcat11no fix listedDEBIAN-CVE-2026-101296
Debian:12tomcat99.0.70-2DEBIAN-CVE-2026-101296
Debian:13tomcat99.0.70-2DEBIAN-CVE-2026-101296
Debian:14tomcat99.0.70-2DEBIAN-CVE-2026-101296
Ubuntu:24.04:LTStomcat10no fix listedUBUNTU-CVE-2026-101296
Ubuntu:26.04:LTStomcat10no fix listedUBUNTU-CVE-2026-101296
Ubuntu:26.10tomcat10no fix listedUBUNTU-CVE-2026-101296
Ubuntu:26.04:LTStomcat11no fix listedUBUNTU-CVE-2026-101296
Ubuntu:26.10tomcat11no fix listedUBUNTU-CVE-2026-101296
Ubuntu:24.04:LTStomcat9no fix listedUBUNTU-CVE-2026-101296
Ubuntu:26.04:LTStomcat9no fix listedUBUNTU-CVE-2026-101296
Ubuntu:26.10tomcat9no fix listedUBUNTU-CVE-2026-101296

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Tomcat 11.0.0-M1 – through 11.0.2610.1.0-M1 – through 10.1.609.0.0.M1 – through 9.0.1228.5.0 – through 8.5.1007.0.0 – through 7.0.109

Weakness: CWE-304 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

References