Vulnerability · Published Sep 27, 2026 · Assigned by VulnCheck

CVE-2026-101043pnpm 11.0.0 before 11.11.0 Environment Variable Exfiltration via Proxy Settings

High 7.4

In plain English

A high-severity security flaw in pnpm from pnpm. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 21% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.4High
Exploit odds (30 days)0.3%top 78.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

pnpm versions 11.0.0 before 11.11.0 and 10.7.0 before 10.34.5 expand ${VAR} environment-variable placeholders in the httpProxy, httpsProxy, and noProxy settings read from a project's pnpm-workspace.yaml. Because the manifest is repository-controlled and the proxy keys were omitted from the request-destination key set that otherwise suppresses placeholder expansion for untrusted manifests (as already done for registry, pnprServer, registries and namedRegistries), an attacker who controls a repository's pnpm-workspace.yaml can cause a victim who clones the repository and runs a pnpm command (e.g. pnpm install) to expand environment secrets such as NPM_TOKEN or GITHUB_TOKEN into a proxy hostname or userinfo and route install traffic — and the corresponding DNS lookups — through an attacker-controlled host. The exfiltration occurs during configuration loading, before any lifecycle script executes. Fixed in pnpm 11.11.0 and 10.34.5.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmpnpm11.11.0GHSA-vx52-2968-3vc6
npmpnpm10.34.5GHSA-vx52-2968-3vc6

Affected products (as reported)

VendorProductVersions
pnpm pnpm 11.0.0 – before 11.11.0
pnpm pnpm 10.7.0 – before 10.34.5

Weakness: CWE-201 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N

References