Vulnerability · Published Sep 26, 2026 · Assigned by VulnCheck

CVE-2026-100701Nodemailer 5.0.0 through 10.0.1 TLS servername Cache Confusion

Medium 5.9

In plain English

A medium-severity improper certificate validation in nodemailer from nodemailer. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 2% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.9Medium
Exploit odds (30 days)0.1%top 98.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Nodemailer versions 5.0.0 through 10.0.1 use a process-global DNS cache that is keyed only by the DNS host, while each cache entry also stores the caller-specific TLS servername. When two direct TLS/SMTPS transports (secure: true) resolve the same non-IP host with different tls.servername values, the first transport's servername is returned on the cache hit and overwrites the second transport's explicitly configured value, so Nodemailer sends the wrong SNI value and validates the peer certificate against the wrong identity. In multi-tenant services or SNI-routed SMTP gateways, an attacker who can prime the cache can cause a victim transport to connect to the attacker's TLS virtual host and accept the attacker's certificate even with rejectUnauthorized: true, disclosing the victim's SMTP credentials. Fixed in 10.0.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12node-nodemailerno fix listedDEBIAN-CVE-2026-100701
Debian:13node-nodemailerno fix listedDEBIAN-CVE-2026-100701
Debian:14node-nodemailer10.0.10+~8.0.1-1DEBIAN-CVE-2026-100701
Ubuntu:22.04:LTSnode-nodemailerno fix listedUBUNTU-CVE-2026-100701
Ubuntu:24.04:LTSnode-nodemailerno fix listedUBUNTU-CVE-2026-100701
Ubuntu:26.04:LTSnode-nodemailerno fix listedUBUNTU-CVE-2026-100701
Ubuntu:26.10node-nodemailerno fix listedUBUNTU-CVE-2026-100701
npmnodemailer10.0.2GHSA-6vj9-mwq6-2f5v

Affected products (as reported)

VendorProductVersions
nodemailer nodemailer 5.0.0 – before 10.0.2

Weakness: CWE-295 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:L/A:N

References